Pyro 1.5.0-foss-2019b-Python-3.7.4

Deprecated: Use of this version of Pyro is deprecated. More information on our Applications Support and Retention Policy.

Pyro is a universal probabilistic programming language (PPL) written in Python and supported by PyTorch on the backend. Pyro enables flexible and expressive deep probabilistic modeling, unifying the best of modern deep learning and Bayesian modeling.

Accessing Pyro 1.5.0-foss-2019b-Python-3.7.4

To load the module for Pyro 1.5.0-foss-2019b-Python-3.7.4 please use this command on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs):

module load Pyro/1.5.0-foss-2019b-Python-3.7.4

BEAR Apps Version

2018b

Extensions

  • opt-einsum-3.3.0
  • Pyro 1.5.0
  • pyro-api-0.1.2

More Information

For more information visit the Pyro website.

Dependencies

This version of Pyro has a direct dependency on: foss/2019b Python/3.7.4-GCCcore-8.3.0 PyTorch/1.6.0-foss-2019b-Python-3.7.4 tqdm/4.41.1-GCCcore-8.3.0

Last modified on 3rd November 2020