SciPy-bundle 2019.03-foss-2019a

Deprecated: Use of this version of SciPy-bundle is deprecated. More information on our Applications Support and Retention Policy.

There is a newer version of SciPy-bundle

Bundle of Python packages for scientific software

Accessing SciPy-bundle 2019.03-foss-2019a

To load the module for SciPy-bundle 2019.03-foss-2019a please use this command on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs):

module load SciPy-bundle/2019.03-foss-2019a

BEAR Apps Version

2018b

Extensions

  • mpi4py 3.0.1
  • mpmath 1.1.0
  • numpy 1.16.2
  • pandas 0.24.2
  • scipy 1.2.1

More Information

For more information visit the SciPy-bundle website.

Dependencies

This version of SciPy-bundle has a direct dependency on: foss/2019a Python/3.7.2-GCCcore-8.2.0 Python/2.7.15-GCCcore-8.2.0

This version of SciPy-bundle is compatible with multiple vesions of Python. At any time, only one of the versions of Python can be active and the desired version of Python should be loaded before loading this version of SciPy-bundle.

Required By

This version of SciPy-bundle is a direct dependent of: ALFA/1.1.1-foss-2019a-Python-3.7.2 basemap/1.2.1-foss-2019a-Python-2.7.15 Biopython/1.73-foss-2019a bokeh/1.3.4-foss-2019a-Python-3.7.2 Bullet/2.88-foss-2019a-Python-3.7.2 Cartopy/0.17.0-foss-2019a-Python-3.7.2 cftime/1.0.3.4-foss-2019a-Python-2.7.15 cftime/1.0.3.4-foss-2019a-Python-3.7.2 corner/2.0.1-foss-2019a-Python-3.7.2 corner/2.0.1-foss-2019a-Python-2.7.15 dask/2.3.0-foss-2019a-Python-3.7.2 emcee/2.2.1-foss-2019a ESMPy/8.0.0-foss-2019a-Python-2.7.15 ESMPy/8.0.0-foss-2019a-Python-3.7.2 flappie/2.0.0-foss-2019a-Python-3.7.2 GDAL/3.0.0-foss-2019a-Python-2.7.15 GDAL/3.0.0-foss-2019a-Python-3.7.2 gensim/3.8.1-foss-2019a-Python-3.7.2 h5py/2.10.0-foss-2019a h5py/2.9.0-foss-2019a HERMESv3_GR/1.0.2-foss-2019a-Python-2.7.15 matplotlib/2.2.4-foss-2019a-Python-2.7.15 matplotlib/3.0.3-foss-2019a-Python-3.7.2 matplotlib/3.1.1-foss-2019a-Python-3.7.2 MoviePy/1.0.1-foss-2019a-Python-3.7.2 networkx/2.3-foss-2019a-Python-3.7.2 NiBabel/2.4.0-foss-2019a NiBabel/3.1.0-foss-2019a-Python-3.7.2 numba/0.43.1-foss-2019a ptemcee/1.0.0-foss-2019a pyblosc/1.8.1-foss-2019a-Python-3.7.2 PyTorch/1.2.0-foss-2019a-Python-3.7.2 rMATS/4.0.2-foss-2019a-Python-2.7.15 scikit-learn/0.21.3-foss-2019a-Python-3.7.2 scikit-learn/0.20.3-foss-2019a spacy/2.1.8-foss-2019a-Python-3.7.2 SPOT-RNA/770ab5c-foss-2019a-Python-3.7.2 statsmodels/0.10.1-foss-2019a talos/0.6.3-foss-2019a-Python-3.7.2 TensorFlow/1.14.0-foss-2019a-Python-3.7.2 TensorFlow/1.13.1-foss-2019a-Python-3.7.2 Theano/1.0.4-foss-2019a VTK/8.2.0-foss-2019a-Python-3.7.2 xarray/0.13.0-foss-2019a-Python-3.7.2 xESMF/0.2.1-foss-2019a-Python-3.7.2

Other Versions

These versions of SciPy-bundle are available on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 5th July 2019