TensorFlow 2.6.0-foss-2021a

Deprecated: Use of this version of TensorFlow is deprecated. More information on our Applications Support and Retention Policy.

There is a newer version of TensorFlow

An open-source software library for Machine Intelligence

Accessing TensorFlow 2.6.0-foss-2021a

To load the module for TensorFlow 2.6.0-foss-2021a please use this command on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs):

module load TensorFlow/2.6.0-foss-2021a

There is a GPU enabled version of this module: TensorFlow 2.6.0-foss-2021a-CUDA-11.3.1

BEAR Apps Version

2018b

Extensions

  • absl-py-0.13.0
  • astor 0.8.1
  • astunparse 1.6.3
  • cachetools 4.2.2
  • clang 5.0
  • dill 0.3.3
  • gast 0.4.0
  • google-auth-1.35.0
  • google-auth-oauthlib-0.4.5
  • google-pasta-0.2.0
  • grpcio 1.39.0
  • gviz-api-1.9.0
  • keras 2.6.0
  • Keras_Preprocessing 1.1.2
  • Markdown 3.3.4
  • oauthlib 3.1.1
  • opt_einsum 3.3.0
  • portpicker 1.4.0
  • pyasn1-modules-0.2.8
  • requests-oauthlib-1.3.0
  • rsa 4.7.2
  • tblib 1.7.0
  • tensorboard 2.6.0
  • tensorboard_data_server 0.6.1
  • tensorboard_plugin_profile 2.5.0
  • tensorboard_plugin_wit 1.8.0
  • TensorFlow 2.6.0
  • tensorflow_estimator 2.6.0
  • termcolor 1.1.0
  • Werkzeug 2.0.1
  • wrapt 1.12.1

More Information

For more information visit the TensorFlow website.

Dependencies

This version of TensorFlow has a direct dependency on: cURL/7.76.0-GCCcore-10.3.0 double-conversion/3.1.5-GCCcore-10.3.0 flatbuffers/2.0.0-GCCcore-10.3.0 flatbuffers-python/2.0-GCCcore-10.3.0 foss/2021a giflib/5.2.1-GCCcore-10.3.0 h5py/3.2.1-foss-2021a hwloc/2.4.1-GCCcore-10.3.0 ICU/69.1-GCCcore-10.3.0 JsonCpp/1.9.4-GCCcore-10.3.0 libjpeg-turbo/2.0.6-GCCcore-10.3.0 libpng/1.6.37-GCCcore-10.3.0 LMDB/0.9.28-GCCcore-10.3.0 NASM/2.15.05-GCCcore-10.3.0 nsync/1.24.0-GCCcore-10.3.0 protobuf-python/3.17.3-GCCcore-10.3.0 Python/3.9.5-GCCcore-10.3.0 snappy/1.1.8-GCCcore-10.3.0 SQLite/3.35.4-GCCcore-10.3.0 typing-extensions/3.10.0.0-GCCcore-10.3.0 zlib/1.2.11-GCCcore-10.3.0

Required By

This version of TensorFlow is a direct dependent of: AlphaFold/2.1.1-foss-2021a deepBlink/0.1.2-foss-2021a pytorch-lightning/1.5.7-foss-2021a-CUDA-11.3.1 pytorch-lightning/1.5.7-foss-2021a

Other Versions

These versions of TensorFlow are available on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 29th November 2021