mpi4py 3.0.2-gompi-2019a-timed-pingpong

MPI for Python (mpi4py) provides bindings of the Message Passing Interface (MPI) standard for the Python programming language, allowing any Python program to exploit multiple processors.

Accessing mpi4py 3.0.2-gompi-2019a-timed-pingpong

To load the module for mpi4py 3.0.2-gompi-2019a-timed-pingpong please use this command on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs):

module load mpi4py/3.0.2-gompi-2019a-timed-pingpong

BEAR Apps Version

2019b

More Information

For more information visit the mpi4py website.

Dependencies

This version of mpi4py has a direct dependency on: gompi/2019a Python/2.7.15-GCCcore-8.2.0 Python/3.7.2-GCCcore-8.2.0

This version of mpi4py is compatible with multiple vesions of Python. At any time, only one of the versions of Python can be active and the desired version of Python should be loaded before loading this version of mpi4py.

Last modified on 21st August 2019