FLTK 1.3.5-GCCcore-9.3.0

Unsupported: Use of this version of FLTK is not supported. More information on our Applications Support and Retention Policy.

There is a newer version of FLTK

FLTK is a cross-platform C++ GUI toolkit for UNIX/Linux (X11), Microsoft Windows, and MacOS X. FLTK provides modern GUI functionality without the bloat and supports 3D graphics via OpenGL and its built-in GLUT emulation.

Accessing FLTK 1.3.5-GCCcore-9.3.0

To load the module for FLTK 1.3.5-GCCcore-9.3.0 please use this command on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs):

module load bear-apps-unsupported/handbuilt/2019
module load FLTK/1.3.5-GCCcore-9.3.0

BEAR Apps Version

2019h

More Information

For more information visit the FLTK website.

Dependencies

This version of FLTK has a direct dependency on: GCCcore/9.3.0 libGLU/9.0.1-GCCcore-9.3.0 libjpeg-turbo/2.0.4-GCCcore-9.3.0 libpng/1.6.37-GCCcore-9.3.0 Mesa/20.0.2-GCCcore-9.3.0 xprop/1.2.4-GCCcore-9.3.0 zlib/1.2.11-GCCcore-9.3.0

Required By

This version of FLTK is a direct dependent of: MIRTK/20210104-fosscuda-2020a-Python-3.8.2 MIRTK/20210104-foss-2020a-Python-3.8.2

Other Versions

These versions of FLTK are available on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 13th January 2021