GCC 12.2.0

Unsupported: Use of this version of GCC is not supported. More information on our Applications Support and Retention Policy.

If you are compiling your own software then we recommend using the foss toolchain, or the fosscuda toolchain if you require CUDA support.


The GNU Compiler Collection includes front ends for C, C++, Objective-C, Fortran, Java, and Ada, as well as libraries for these languages (libstdc++, libgcj,...).

Accessing GCC 12.2.0

To load the module for GCC 12.2.0 please use this command on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs):

module load bear-apps-unsupported/handbuilt/2019
module load GCC/12.2.0

BEAR Apps Version

2019h

More Information

For more information visit the GCC website.

Dependencies

This version of GCC has a direct dependency on: binutils/2.39-GCCcore-12.2.0 GCCcore/12.2.0

Required By

This version of GCC is a direct dependent of: BamTools/2.5.2-GCC-12.2.0 BCFtools/1.17-GCC-12.2.0 BEDTools/2.30.0-GCC-12.2.0 BLIS/0.9.0-GCC-12.2.0 Boost/1.81.0-GCC-12.2.0 Boost.Python/1.81.0-GCC-12.2.0 Bowtie/1.3.1-GCC-12.2.0 FFTW/3.3.10-GCC-12.2.0 FlexiBLAS/3.2.1-GCC-12.2.0 foss/2022b GEOS/3.11.1-GCC-12.2.0 gfbf/2022b gompi/2022b GSL/2.7-GCC-12.2.0 GST-plugins-bad/1.22.5-GCC-12.2.0 GTK4/4.11.3-GCC-12.2.0 HTSlib/1.17-GCC-12.2.0 libxc/6.1.0-GCC-12.2.0 OpenBLAS/0.3.21-GCC-12.2.0 OpenMPI/4.1.4-GCC-12.2.0 SAMtools/1.17-GCC-12.2.0 STAR/2.7.11a-GCC-12.2.0

Other Versions

These versions of GCC are available on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 14th July 2023