PyQt5 5.13.1-GCCcore-8.3.0-Python-3.7.4

Unsupported: Use of this version of PyQt5 is not supported. More information on our Applications Support and Retention Policy.

There is a newer version of PyQt5

PyQt5 is a set of Python bindings for v5 of the Qt application framework from The Qt Company.

Accessing PyQt5 5.13.1-GCCcore-8.3.0-Python-3.7.4

To load the module for PyQt5 5.13.1-GCCcore-8.3.0-Python-3.7.4 please use this command on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs):

module load bear-apps-unsupported/handbuilt/2019
module load PyQt5/5.13.1-GCCcore-8.3.0-Python-3.7.4

BEAR Apps Version

2019h

Known Issues

QtWebEngine is not available for POWER systems. This means that the build of PyQt5 for the POWER9 nodes does not include PyQtWebEngine.

More Information

For more information visit the PyQt5 website.

Dependencies

This version of PyQt5 has a direct dependency on: GCCcore/8.3.0 Python/3.7.4-GCCcore-8.3.0 Qt5/5.13.1-GCCcore-8.3.0

Required By

This version of PyQt5 is a direct dependent of: ETE/3.1.2-foss-2019b-Python-3.7.4 mayavi/4.7.1-foss-2019b-Python-3.7.4 refnx/0.1.17-foss-2019b-Python-3.7.4

Other Versions

These versions of PyQt5 are available on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 18th May 2020