SciPy-bundle 2020.11-foss-2020b

Unsupported: Use of this version of SciPy-bundle is not supported. More information on our Applications Support and Retention Policy.

There is a newer version of SciPy-bundle

Bundle of Python packages for scientific software

Accessing SciPy-bundle 2020.11-foss-2020b

To load the module for SciPy-bundle 2020.11-foss-2020b please use this command on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs):

module load bear-apps-unsupported/handbuilt/2019
module load SciPy-bundle/2020.11-foss-2020b

There is a GPU enabled version of this module: SciPy-bundle 2020.11-fosscuda-2020b

BEAR Apps Version

2019h

Extensions

  • Bottleneck 1.3.2
  • deap 1.3.1
  • mpi4py 3.0.3
  • mpmath 1.1.0
  • numexpr 2.7.1
  • numpy 1.19.4
  • pandas 1.1.4
  • scipy 1.5.4

More Information

For more information visit the SciPy-bundle website.

Dependencies

This version of SciPy-bundle has a direct dependency on: foss/2020b pybind11/2.6.0-GCCcore-10.2.0 Python/3.8.6-GCCcore-10.2.0

Required By

This version of SciPy-bundle is a direct dependent of: Arrow/0.17.1-foss-2020b astropy/4.2.1-foss-2020b basemap/1.2.2-foss-2020b Biopython/1.78-foss-2020b bokeh/2.3.1-foss-2020b Cartopy/0.18.0-foss-2020b cell2location/0.05-alpha-foss-2020b CellPhoneDB/3.1.0-foss-2020b Compass/20220402-foss-2020b cpl/7.1.4-foss-2020b cryoDRGN/0.3.5-foss-2020b dask/2021.4.0-foss-2020b eccodes-python/1.1.0-foss-2020b emcee/3.0.2-foss-2020b ESMPy/8.0.1-foss-2020b espdr/2.3.3-foss-2020b GCPy/1.0.3-foss-2020b GDAL/3.2.1-foss-2020b gensim/3.8.3-foss-2020b geopandas/0.9.0-foss-2020b GeoRinex/1.16.1-foss-2020b GROMACS/2021.2-foss-2020b h5py/2.10.0-foss-2020b h5py/3.1.0-foss-2020b holoviews/1.14.3-foss-2020b hyperopt/0.2.5-foss-2020b IOHexperimenter/0.2.9.2-foss-2020b iterative-Random-Forest/0.2.5-foss-2020b matplotlib/3.3.3-foss-2020b mofapy2/0.5.7-foss-2020b netcdf4-python/1.5.5.1-foss-2020b networkx/2.5-foss-2020b nevergrad/0.4.3.post4-foss-2020b numba/0.52.0-foss-2020b numba/0.53.1-foss-2020b OpenCV/4.5.1-foss-2020b-contrib OpenMC/0.12.1-foss-2020b PLUMED/2.6.2-foss-2020b pyfits/3.5-foss-2020b pymap3d/2.7.2-foss-2020b PyMC3/3.11.1-foss-2020b pyro-ppl/1.5.2-foss-2020b PyTables/3.6.1-foss-2020b python-cdo/1.5.6-foss-2020b PyTorch/1.7.1-foss-2020b rMATS-turbo/4.1.1-foss-2020b scikit-learn/0.23.2-foss-2020b statsmodels/0.12.1-foss-2020b tensorboardX/2.4-foss-2020b-PyTorch-1.7.1 Theano/1.1.2-foss-2020b-PyMC TumorDecon/1.1.1-foss-2020b umap-learn/0.4.6-foss-2020b vasprun-xml/1.0.4-foss-2020b visdom/0.1.8.9-foss-2020b VTK/9.0.1-foss-2020b wxPython/4.1.1-foss-2020b xarray/0.16.2-foss-2020b xESMF/0.3.0-foss-2020b

Other Versions

These versions of SciPy-bundle are available on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 22nd February 2021