gmpy2 2.1.0b5-GCC-9.3.0

Unsupported: Use of this version of gmpy2 is not supported. More information on our Applications Support and Retention Policy.

There is a newer version of gmpy2

GMP/MPIR, MPFR, and MPC interface to Python 2.6+ and 3.x

Accessing gmpy2 2.1.0b5-GCC-9.3.0

To load the module for gmpy2 2.1.0b5-GCC-9.3.0 please use this command on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs):

module load bear-apps-unsupported/handbuilt/2019
module load gmpy2/2.1.0b5-GCC-9.3.0

BEAR Apps Version

2019h

More Information

For more information visit the gmpy2 website.

Dependencies

This version of gmpy2 has a direct dependency on: GCC/9.3.0 GMP/6.2.0-GCCcore-9.3.0 MPC/1.1.0-GCC-9.3.0 MPFR/4.0.2-GCCcore-9.3.0 Python/2.7.18-GCCcore-9.3.0 Python/3.8.2-GCCcore-9.3.0

This version of gmpy2 is compatible with multiple vesions of Python. At any time, only one of the versions of Python can be active and the desired version of Python should be loaded before loading this version of gmpy2.

Required By

This version of gmpy2 is a direct dependent of: sympy/1.6.2-foss-2020a-Python-3.8.2

Other Versions

These versions of gmpy2 are available on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Version BEAR Apps Version
2.1.2-GCC-11.3.0 2022a

Last modified on 3rd February 2021