PyTorch 1.12.1-foss-2022a-CUDA-11.7.0

There is a newer version of PyTorch

PyTorch provides tensor computation with strong GPU acceleration and deep neural networks built on a tape-based autograd system.

Accessing PyTorch 1.12.1-foss-2022a-CUDA-11.7.0

To load the module for PyTorch 1.12.1-foss-2022a-CUDA-11.7.0 please use this command on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs):

module load PyTorch/1.12.1-foss-2022a-CUDA-11.7.0

There is a CPU version of this module: PyTorch 1.12.1-foss-2022a

BEAR Apps Version

2020a

More Information

For more information visit the PyTorch website.

Dependencies

This version of PyTorch has a direct dependency on: CUDA/11.7.0 cuDNN/8.4.1.50-CUDA-11.7.0 expecttest/0.1.3-GCCcore-11.3.0 FFmpeg/4.4.2-GCCcore-11.3.0 foss/2022a GMP/6.2.1-GCCcore-11.3.0 magma/2.6.2-foss-2022a-CUDA-11.7.0 MPFR/4.1.0-GCCcore-11.3.0 NCCL/2.12.12-GCCcore-11.3.0-CUDA-11.7.0 Ninja/1.10.2-GCCcore-11.3.0 numactl/2.0.14-GCCcore-11.3.0 Pillow/9.1.1-GCCcore-11.3.0 protobuf/3.19.4-GCCcore-11.3.0 protobuf-python/3.19.4-GCCcore-11.3.0 pybind11/2.9.2-GCCcore-11.3.0 Python/3.10.4-GCCcore-11.3.0 PyYAML/6.0-GCCcore-11.3.0 SciPy-bundle/2022.05-foss-2022a

Required By

This version of PyTorch is a direct dependent of: cell2location/0.1.3-foss-2022a-CUDA-11.7.0 Cellpose/2.2-foss-2022a-CUDA-11.7.0 DeepLabCut/2.3.6-foss-2022a-CUDA-11.7.0 ont-remora/2.0.0-foss-2022a-CUDA-11.7.0 ptwt/0.1.4.post2-foss-2022a-CUDA-11.7.0 pyperlin/1.1.0-foss-2022a-CUDA-11.7.0 PyTorch-Lightning/1.9.3-foss-2022a-CUDA-11.7.0 Transformers/4.24.0-foss-2022a-CUDA-11.7.0

Other Versions

These versions of PyTorch are available on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 21st January 2023