Python 3.6.6-foss-2018b

There is a newer version of Python

Python is a programming language that lets you work more quickly and integrate your systems more effectively.

Accessing Python 3.6.6-foss-2018b

To load the module for Python 3.6.6-foss-2018b please use this command on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs):

module load Python/3.6.6-foss-2018b

BEAR Apps Version

2020a

Extensions

  • asn1crypto 0.24.0
  • bcrypt 3.1.4
  • bitstring 3.1.5
  • blist 1.3.6
  • certifi 2018.8.13
  • cffi 1.11.5
  • chardet 3.0.4
  • cryptography 2.3.1
  • Cython 0.28.5
  • deap 1.2.2
  • decorator 4.3.0
  • docopt 0.6.2
  • ecdsa 0.13
  • idna 2.7
  • joblib 0.12.2
  • liac-arff-2.3
  • mock 2.0.0
  • mpi4py 3.0.0
  • mpmath 1.0.0
  • netaddr 0.7.19
  • netifaces 0.10.7
  • nose 1.3.7
  • numpy 1.15.0
  • pandas 0.23.4
  • paramiko 2.4.1
  • paycheck 1.0.2
  • pbr 4.2.0
  • pip 18.0
  • py_expression_eval 0.3.4
  • pyasn1 0.4.4
  • pycparser 2.18
  • pycrypto 2.6.1
  • PyNaCl 1.2.1
  • pyparsing 2.2.0
  • python-dateutil-2.7.3
  • pytz 2018.5
  • requests 2.19.1
  • scipy 1.1.0
  • setuptools 40.0.0
  • six 1.11.0
  • tabulate 0.8.2
  • urllib3 1.23
  • virtualenv 16.0.0
  • xlrd 1.1.0

More Information

For more information visit the Python website.

Dependencies

This version of Python has a direct dependency on: bzip2/1.0.6-GCCcore-7.3.0 foss/2018b GMP/6.1.2-GCCcore-7.3.0 libffi/3.2.1-GCCcore-7.3.0 libreadline/7.0-GCCcore-7.3.0 ncurses/6.1-GCCcore-7.3.0 SQLite/3.24.0-GCCcore-7.3.0 XZ/5.2.4-GCCcore-7.3.0 zlib/1.2.11-GCCcore-7.3.0

Required By

This version of Python is a direct dependent of: amplimap/0.4.16-foss-2018b-Python-3.6.6 amplimap/0.4.5-foss-2018b-Python-3.6.6 ariba/2.13.5-foss-2018b-Python-3.6.6 Biopython/1.72-foss-2018b-Python-3.6.6 Boost.Python/1.67.0-foss-2018b-Python-3.6.6 cellphonedb/1.1.0-foss-2018b-Python-3.6.6 CGAL/4.11.1-foss-2018b-Python-3.6.6 cget/0.1.7-foss-2018b-Python-3.6.6 chiron/0.4.2-foss-2018b-Python-3.6.6 dask/0.19.4-foss-2018b-Python-3.6.6 Deepbinner/0.2.0-foss-2018b-Python-3.6.6 DendroPy/4.4.0-foss-2018b-Python-3.6.6 dnaMD/2.1.0-foss-2018b-Python-3.6.6 ETE/3.1.1-foss-2018b-Python-3.6.6 FLANN/1.8.4-foss-2018b-Python-3.6.6 future/0.16.0-foss-2018b-Python-3.6.6 GATK/4.1.0.0-foss-2018b-Python-3.6.6 GDAL/2.2.3-foss-2018b-Python-3.6.6 GEOS/3.6.2-foss-2018b-Python-3.6.6 GitPython/2.1.11-foss-2018b-Python-3.6.6 gmsh/4.2.2-foss-2018b-Python-3.6.6 gubbins/2.3.4-foss-2018b-Python-3.6.6 GUDHI/2.3.0-foss-2018b-Python-3.6.6 h5py/2.8.0-foss-2018b-Python-3.6.6 HAPDeNovo/fe8bcc2-foss-2018b-Python-3.6.6 hdf5storage/0.1.15-foss-2018b-Python-3.6.6 hypothesis/4.5.0-foss-2018b-Python-3.6.6 IPython/6.4.0-foss-2018b-Python-3.6.6 JARVIS/2018.11.7-foss-2018b-Python-3.6.6 Keras/2.2.4-foss-2018b-Python-3.6.6 lxml/4.2.5-foss-2018b-Python-3.6.6 mappy/2.15-foss-2018b-Python-3.6.6 matplotlib/3.0.0-foss-2018b-Python-3.6.6 matplotlib/3.1.0-foss-2018b-Python-3.6.6 mayavi/4.6.2-foss-2018b-Python-3.6.6 mayavi/4.7.0-foss-2018b-Python-3.6.6 mne/0.17.2-foss-2018b-Python-3.6.6 MoviePy/1.0.0-foss-2018b-Python-3.6.6 networkx/2.2-foss-2018b-Python-3.6.6 NiBabel/2.3.0-foss-2018b-Python-3.6.6 numexpr/2.6.5-foss-2018b-Python-3.6.6 ont-fast5-api/1.3.0-foss-2018b-Python-3.6.6 Open3D/0.5.0.0-foss-2018b-Python-3.6.6 OptiType/1.3.2-foss-2018b-Python-3.6.6 PCL/1.9.1-foss-2018b-Python-3.6.6 picopore/1.2.0-foss-2018b-Python-3.6.6 Pillow/5.3.0-foss-2018b-Python-3.6.6 Pillow-SIMD/5.0.0-foss-2018b-Python-3.6.6 pkgconfig/1.3.1-foss-2018b-Python-3.6.6 protobuf-python/3.6.0-foss-2018b-Python-3.6.6 psutil/5.4.7-foss-2018b-Python-3.6.6 pybind11/2.2.4-foss-2018b-Python-3.6.6 pyblosc/1.8.1-foss-2018b-Python-3.6.6 pyEMMA/2.5.5-foss-2018b-Python-3.6.6 PyNGL/1.6.1-foss-2018b-Python-3.6.6 PyNIO/1.5.5-foss-2018b-Python-3.6.6 Pyomo/5.5.0-foss-2018b-Python-3.6.6 PyQt5/5.11.3-foss-2018b-Python-3.6.6 Pysam/0.15.1-foss-2018b-Python-3.6.6 Pysam/0.13-foss-2018b-Python-3.6.6 PyTables/3.4.4-foss-2018b-Python-3.6.6 pytest/4.4.0-foss-2018b-Python-3.6.6 PyTorch/1.0.1-foss-2018b-Python-3.6.6 PyTorch/0.4.1-foss-2018b-Python-3.6.6 PyTorch/1.1.0-foss-2018b-Python-3.6.6 PyYAML/3.13-foss-2018b-Python-3.6.6 regex/2019.06.08-foss-2018b-Python-3.6.6 rpy2/3.0.5-foss-2018b-Python-3.6.6 scikit-image/0.15.0-foss-2018b-Python-3.6.6 scikit-learn/0.20.0-foss-2018b-Python-3.6.6 scikit-multiflow/0.2.0-foss-2018b-Python-3.6.6 scipy/1.2.0-foss-2018b-Python-3.6.6 Scoary/1.6.16-foss-2018b-Python-3.6.6 Seaborn/0.9.0-foss-2018b-Python-3.6.6 snakemake/5.2.4-foss-2018b-Python-3.6.6 Sphinx/1.8.1-foss-2018b-Python-3.6.6 statsmodels/0.9.0-foss-2018b-Python-3.6.6 SWIG/3.0.12-foss-2018b-Python-3.6.6 talos/0.4.9-foss-2018b-Python-3.6.6 tb_nightly/1.14.0a20190509-foss-2018b-Python-3.6.6 TensorFlow/1.10.1-foss-2018b-Python-3.6.6 TensorFlow/1.13.1-foss-2018b-Python-3.6.6 tensorflow-probability/0.6.0-foss-2018b-Python-3.6.6 Theano/1.0.3-foss-2018b-Python-3.6.6 Theano/1.0.4-foss-2018b-Python-3.6.6 tigramite/4.0.0-beta-foss-2018b-Python-3.6.6 Tkinter/3.6.6-foss-2018b-Python-3.6.6 torchvision/0.2.2-foss-2018b-Python-3.6.6 TraCeR/0.6.0-foss-2018b-Python-3.6.6 ViennaRNA/2.4.11-foss-2018b-Python-3.6.6 VTK/8.1.1-foss-2018b-Python-3.6.6 WhatsHap/0.18-foss-2018b-Python-3.6.6 wheel/0.31.1-foss-2018b-Python-3.6.6 xarray/0.12.1-foss-2018b-Python-3.6.6

Other Versions

These versions of Python are available on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 3rd June 2019