ANSYS 2021R1

There is a newer version of ANSYS

Ansys Fluent and Ansys CFX provide CFD modelling.

Accessing ANSYS 2021R1

To load the module for ANSYS 2021R1 please use this command on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs):

module load ANSYS/2021R1

BEAR Apps Version

2020b

ANSYS Licensing

IT Services funds some Academic licences, but these do not provide all of the facilities in the whole range of Ansys packages. To see which features are available on these licenses, visit the Ansys Academic Products page; the IT Services' license covers products in the ANSYS Academic Research CFD and the ANSYS Academic Research HPC groups. Any additional features would have to be funded by the research groups who need to use them; contact the IT Service Desk if this is required.

Known Problems and Limitations

Ansys does not support remote display of some graphics, including CFX_Pre and CFD_Post, to a PC using Exceed3D.

If you are trying to use Platform MPI for a parallel job there are situations where the job may fail. If this is the case try running the job again but include the line below in your job script (Source: https://www.cfd-online.com/Forums/cfx/161036-error-while-running-cfx-parallel-configuration.html):

unset SLURM_GTIDS

Parallel ANSYS and Fluent Jobs

We provide a helper script to generate the nodefile for parallel ANSYS jobs: module load slurm-helpers
NODEFILE=$(make_nodelist)
This can be provided to CFX with: -par-dist "${NODEFILE}" Or to Fluent with: -cnf=${NODEFILE}

More Information

For more information visit the ANSYS website.

Dependencies

This version of ANSYS has a direct dependency on: libpng/1.2.59

Other Versions

These versions of ANSYS are available on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Version BEAR Apps Version
2023R1 2022a

Last modified on 17th May 2021