hyperopt 0.2.5-fosscuda-2020b

Distributed Asynchronous Hyperparameter Optimization in Python

Accessing hyperopt 0.2.5-fosscuda-2020b

To load the module for hyperopt 0.2.5-fosscuda-2020b please use this command on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs):

module load hyperopt/0.2.5-fosscuda-2020b

There is a CPU version of this module: hyperopt 0.2.5-foss-2020b

BEAR Apps Version

2020h

Extensions

  • cloudpickle 1.6.0
  • hyperopt 0.2.5
  • lightgbm 3.2.0
  • py4j 0.10.9.2
  • pymongo 3.11.3

More Information

For more information visit the hyperopt website.

Dependencies

This version of hyperopt has a direct dependency on: fosscuda/2020b Java/11 networkx/2.5-fosscuda-2020b Python/3.8.6-GCCcore-10.2.0 scikit-learn/0.23.2-fosscuda-2020b SciPy-bundle/2020.11-fosscuda-2020b Spark/3.1.1-fosscuda-2020b tqdm/4.56.2-GCCcore-10.2.0

Required By

This version of hyperopt is a direct dependent of: cell2location/0.05-alpha-fosscuda-2020b

Other Versions

These versions of hyperopt are available on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Version BEAR Apps Version
0.2.5-foss-2020b 2020b

Last modified on 28th July 2021