GTK4 4.11.3-GCC-12.2.0

GTK+ is the primary library used to construct user interfaces in GNOME. It provides all the user interface controls, or widgets, used in a common graphical application. Its object-oriented API allows you to construct user interfaces without dealing with the low-level details of drawing and device interaction.

Accessing GTK4 4.11.3-GCC-12.2.0

To load the module for GTK4 4.11.3-GCC-12.2.0 please use this command on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs):

module load GTK4/4.11.3-GCC-12.2.0

BEAR Apps Version

2021a

More Information

For more information visit the GTK4 website.

Dependencies

This version of GTK4 has a direct dependency on: ATK/2.38.0-GCCcore-12.2.0 at-spi2-atk/2.38.0-GCCcore-12.2.0 FriBidi/1.0.12-GCCcore-12.2.0 GCC/12.2.0 Gdk-Pixbuf/2.42.10-GCCcore-12.2.0 GST-plugins-bad/1.22.5-GCC-12.2.0 libepoxy/1.5.10-GCCcore-12.2.0 Pango/1.50.12-GCCcore-12.2.0 PyGObject/3.44.1-GCCcore-12.2.0 Wayland/1.22.0-GCCcore-12.2.0 X11/20221110-GCCcore-12.2.0

Required By

This version of GTK4 is a direct dependent of: OpenCV/4.8.0-foss-2022b-contrib

Other Versions

These versions of GTK4 are available on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Version BEAR Apps Version
4.7.0-GCC-11.3.0 2022a

Last modified on 26th July 2023