matplotlib 3.3.3-foss-2020b

There is a newer version of matplotlib

matplotlib is a python 2D plotting library which produces publication quality figures in a variety of hardcopy formats and interactive environments across platforms. matplotlib can be used in python scripts, the python and ipython shell, web application servers, and six graphical user interface toolkits.

Accessing matplotlib 3.3.3-foss-2020b

To load the module for matplotlib 3.3.3-foss-2020b please use this command on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs):

module load bear-apps/2022a
module load matplotlib/3.3.3-foss-2020b

There is a GPU enabled version of this module: matplotlib 3.3.3-fosscuda-2020b

BEAR Apps Version

2022a

Extensions

  • Cycler 0.10.0
  • kiwisolver 1.3.0
  • matplotlib 3.3.3

More Information

For more information visit the matplotlib website.

Dependencies

This version of matplotlib has a direct dependency on: foss/2020b freetype/2.10.3-GCCcore-10.2.0 libpng/1.6.37-GCCcore-10.2.0 Pillow/8.0.1-GCCcore-10.2.0 Python/3.8.6-GCCcore-10.2.0 SciPy-bundle/2020.11-foss-2020b Tkinter/3.8.6-GCCcore-10.2.0

Required By

This version of matplotlib is a direct dependent of: basemap/1.2.2-foss-2020b Cartopy/0.18.0-foss-2020b cell2location/0.05-alpha-foss-2020b cpl/7.1.4-foss-2020b cryoDRGN/0.3.5-foss-2020b espdr/2.3.3-foss-2020b GCPy/1.0.3-foss-2020b geopandas/0.9.0-foss-2020b iterative-Random-Forest/0.2.5-foss-2020b molmod/1.4.5-foss-2020b OpenMC/0.12.1-foss-2020b PyMC3/3.11.1-foss-2020b Seaborn/0.11.1-foss-2020b TumorDecon/1.1.1-foss-2020b vasprun-xml/1.0.4-foss-2020b

Other Versions

These versions of matplotlib are available on the BEAR systems (BlueBEAR, BEAR Cloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 27th April 2021