Qt5 5.15.2-GCCcore-10.3.0

There is a newer version of Qt5

Qt is a comprehensive cross-platform C++ application framework.

Accessing Qt5 5.15.2-GCCcore-10.3.0

To load the module for Qt5 5.15.2-GCCcore-10.3.0 please use this command on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs):

module load Qt5/5.15.2-GCCcore-10.3.0

BEAR Apps Version

2021a

Architectures

EL8-cascadelakeEL8-haswellEL8-icelake

The listed architectures consist of two part: OS-CPU.

  • BlueBEAR: The OS used on BlueBEAR is represented by EL and there are several different processor (CPU) types available on BlueBEAR. More information about the processor types on BlueBEAR is available on the BlueBEAR Job Submission page.
  • BEAR and CaStLeS Cloud VMs: These VMs can have one of two OSes. Those with access to a BEAR Cloud or CaStLeS VM should check that the listed architectures for an application include the OS of VM being used. The VMs, irrespective of OS, will use the haswell CPU type.

More Information

For more information visit the Qt5 website.

Dependencies

This version of Qt5 has a direct dependency on: bzip2/1.0.8-GCCcore-10.3.0 DBus/1.13.18-GCCcore-10.3.0 double-conversion/3.1.5-GCCcore-10.3.0 fontconfig/2.13.93-GCCcore-10.3.0 GCCcore/10.3.0 GLib/2.68.2-GCCcore-10.3.0 JasPer/2.0.28-GCCcore-10.3.0 libevent/2.1.12-GCCcore-10.3.0 libGLU/9.0.1-GCCcore-10.3.0 libjpeg-turbo/2.0.6-GCCcore-10.3.0 libpng/1.6.37-GCCcore-10.3.0 NSS/3.65-GCCcore-10.3.0 OpenSSL/1.1 PCRE2/10.36-GCCcore-10.3.0 snappy/1.1.8-GCCcore-10.3.0 X11/20210518-GCCcore-10.3.0

Required By

This version of Qt5 is a direct dependent of: CloudCompare/2.12.0-foss-2021a ConnectomeWorkbench/1.5.0-GCCcore-10.3.0 gnuplot/5.4.2-GCCcore-10.3.0 MRtrix/3.0.3-foss-2021a PyQt5/5.15.4-GCCcore-10.3.0 Qwt/6.1.5-GCCcore-10.3.0

Other Versions

These versions of Qt5 are available on the BEAR systems (BlueBEAR, BEARCloud VMs, and CaStLeS VMs). These will be retained in accordance with our Applications Support and Retention Policy.

Last modified on 11th October 2021